Error occurred while trying to proxy request

在npm start 本地起项目的时候修改了域名,然后就出现了报错如下:
[HPM] Error occurred while trying to proxy request /vtl/bulletin/unread/count from localhost:8080

这个是本地的服务器连接不上远程服务器的数据。可能出错的原因是node版本太低,或者是hosts文件没和本地的绑定。本次就来讲解升级node的方法。

node 的更新:

1、检查 node 的当前版本,使用命令

node -v

2、清除npm cache

sudo npm cache clean -f

3、安装 n 模块

sudo npm install -g n

4、安装最新的稳定版本

sudo n stable

你也可以定制一个自己喜欢的版本:

sudo n 8.1.2

5、查看 node 的版本,检查升级是否成功

node -v
点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注